Microsoft 365 issues
Incident Report for University of Louisville
Resolved
Microsoft has resolved the network issue and systems have returned to normal operation
Posted Oct 07, 2020 - 16:18 EDT
Identified
Microsoft has identified a networking issue intermittently affecting access to Microsoft 365 services.
Posted Oct 07, 2020 - 15:32 EDT
Update
The situation seems to be improving, but Microsoft has not provided a status update yet. We are monitoring the situation.
Posted Oct 07, 2020 - 15:22 EDT
Update
Teams is also being very slow to update and some people are unable to join meetings.
Posted Oct 07, 2020 - 14:53 EDT
Investigating
Microsoft is having an issue with Exchange Online that is causing Outlook to hang or crash. Restarting Outlook resolves the problem for most people. ITS is investigating.
Posted Oct 07, 2020 - 14:51 EDT
This incident affected: Microsoft 365.