Microsoft Safelinks marking legitimate sites as malicious
Incident Report for University of Louisville
Resolved
This incident has been resolved.
Posted May 10, 2021 - 15:29 EDT
Update
We believe that this has been resolved for UofL users, but are continuing to monitor.
Posted May 10, 2021 - 14:02 EDT
Monitoring
Microsoft has made changes in their environment to address this problem. We are monitoring the situation to see when those changes become effective for us. The next update from Microsoft is expected after 1:30pm
Posted May 10, 2021 - 11:34 EDT
Identified
Microsoft has replicated this problem within their internal testing environment. Impacted links include, but are not limited to, YouTube, Google, Yahoo, Facebook. Next update from Microsoft is expected around 11:30AM
Posted May 10, 2021 - 10:12 EDT
Investigating
We are investigating several instances of Microsoft marking legitimate websites as malicious.
Posted May 10, 2021 - 10:01 EDT
This incident affected: Microsoft 365.