ITS Helpdesk Unable to Take Calls
Incident Report for University of Louisville
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 07:52 EDT
Monitoring
Our telephone provider believes that they have resolved the problem and the ITS Helpdesk is once again able to take calls. We are continuing to monitor the system to make certain that it is stable.
Posted Oct 21, 2020 - 07:40 EDT
Investigating
The ITS Helpdesk is currently unable to accept phone calls. We are working with our telephone carrier to identify the problem. The ITS Helpdesk is still available via our Live Chat service. Click the live chat icon on https://louisville.edu/its/get-help/its-helpdesk to connect.
Posted Oct 21, 2020 - 07:04 EDT