ITS Helpdesk Experiencing Phone Problems
Incident Report for University of Louisville
Resolved
This incident has been resolved.
Posted Oct 22, 2020 - 07:21 EDT
Investigating
The ITS Helpdesk is currently experiencing difficulties answering phone calls. LiveChat is available. https://louisville.edu/its/get-help/its-helpdesk
Posted Oct 22, 2020 - 07:08 EDT